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Nivel técnico: MEDIO
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Actualizado: Mar-2022
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English Version
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Alison Desktop AD (>3.2.1)

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DigiCert Desktop Client DDC (>3.2.1)

\uD83E\uDD14 Inconveniente

El problema se presenta con los siguientes síntomas:

  • Aunque se ha realizado la habilitación, no avanza de dicho paso en el asistente de instalación:

Casos particulares

También se ha detectado que esta solución puede ser aplicada para esos casos particulares:

Al acceder a https://www.santander.com.ar/banco/online/empresas >> Online Banking Empresas se muestra este pop up y no permite continuar operando.

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🌱 Diagnóstico

Para diagnosticar el motivo realice el siguiente paso: acceda a https://127.0.0.1:8004/V2/system en una ventana del navegador. Las posibles respuestas se muestran a continuación:


Conexión exitosa

Sin conexión

Conexión no confiable

Alison-Desktop está escuchando, es confiable y se puede comunicar sin problema.

Alison-Desktop no está escuchando en el puerto de conexión.

Alison-Desktop está escuchando pero el certificado no es confiable.

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(thumbs up) Conexión exitosa

Alison-Desktop está escuchando, es confiable y se puede comunicar sin problema.


(thumbs down) Sin conexión

Alison-Desktop no está escuchando en el puerto de conexión. Es posible que la aplicación no cuente con el certificado de conexión correctamente generado.


(thumbs down) Conexión no confiable

Alison-Desktop está escuchando pero el certificado no es confiable. Es posible que no haya habilitado correctamente la aplicación u otra aplicación (Antivirus o EndPoint-Protection) esté alterando esta comunicación.


🧐 Motivos y Soluciones

1️⃣ KeyStore de conexión inexistente

Motivo:

no existe el archivo .alison-desktop/connector/AlisonConnector.jks

Solución:

Borrar los archivos de la carpeta /connector y el archivo config/default.alison-desktop correspondiente al usuario, tal como se describe en los Archivos Principales.

Code Block
C:\Users\<user>\.alison-desktop\connector
C:\Users\<user>\.alison-desktop\config\default.alison-desktop

Reiniciar (blue star) Alison Desktop. Estos archivos serán regenerados nuevamente y debe habilitar la aplicación nuevamente.

2️⃣ Otro programa está escuchando en el puerto 8004

Motivo:

Detectar qué otro programa genera el conflicto:

2.1- Abra una consola y ejecute el siguiente comando: netstat -ano | find "8004" para verificar que sí existe un programa escuchando y obtener el PID.

2.2 Ejecute en la misma consola el comando: tasklist /fi "PID eq "<nro marcado en rojo>" para verificar qué proceso esta escuchando en el puerto “8004”

Solución:

desinstale o cierre el programa que genera conflicto.

3️⃣ Solucionar con Plug-in

Instalar Alison Extension (Plug-in)


(warning) En caso de no poder resolver el inconveniente:

Para poder avanzar con un diagnóstico más preciso, necesitamos que por favor acceda al los datos del certificado tal como se muestran en la siguientes imagenes:

Es necesario que nos remita la información del certificado, tal como se muestra a continuación, donde se puede ver en detalle la descripción correspondiente a “Issuer Name”.


Info
Nota: si encuentra que esta información contiene algún error, o es incompleta, por favor comunicarse con soporte@certisur.com
Muchas gracias.