Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.
Panel
panelIconId1f39a
panelIcon:level_slider:
panelIconText🎚
bgColor#ABF5D1
Nivel técnico: MEDIO
Panel
panelIconId1f551
panelIcon:clock2:
panelIconText🕑
bgColor#F4F5F7
Actualizado: Mar-2022
Panel
panelIconId1f1ec-1f1e7
panelIcon:flag_gb:
panelIconText🇬🇧
bgColor#F4F5F7
English Version
Panel
panelIconId1f4c0
panelIcon:dvd:
panelIconText📀
bgColor#E3FCEF

Alison Desktop AD (+3.2.1)

Panel
panelIconId1f4bf
panelIcon:cd:
panelIconText💿
bgColor#DEEBFF

DigiCert Desktop Client DDC (+3.2.1)

\uD83E\uDD14 Inconveniente

El problema se presenta con los siguientes síntomas:

  • Aunque se ha realizado la habilitación, no avanza de dicho paso en el asistente de instalación:

Image Modified

Image Modified

🌱 Diagnóstico

Para diagnosticar el motivo realice el siguiente paso: acceda a https://127.0.0.1:8004/V2/system en una ventana del navegador. Las posibles respuestas se muestran a continuación:


Conexión exitosa

Sin conexión

Conexión no confiable

Alison-Desktop está escuchando, es confiable y se puede comunicar sin problema.

Alison-Desktop no está escuchando en el puerto de conexión.

Alison-Desktop está escuchando pero el certificado no es confiable.

Image Modified

...

Image Added

...

Image Added


(thumbs up) Conexión exitosa

Alison-Desktop está escuchando, es confiable y se puede comunicar sin problema.

...

Image Added


(thumbs down) Sin conexión

Alison-Desktop no está escuchando en el puerto de conexión. Es posible que la aplicación no cuente con el certificado de conexión correctamente generado.

Image Modified

(thumbs down) Conexión no confiable

Alison-Desktop está escuchando pero el certificado no es confiable. Es posible que no haya habilitado correctamente la aplicación u otra aplicación (Antivirus o EndPoint-Protection) esté alterando esta comunicación.

Image Modified

🧐 Motivos y Soluciones

1️⃣ KeyStore de conexión inexistente

Motivo:

no existe el archivo .alison-desktop/connector/AlisonConnector.jks

Solución:

Borrar los archivos de la carpeta /connector y el archivo config/default.alison-desktop correspondiente al usuario, tal como se describe en los Archivos Principales.

Code Block
C:\Users\<user>\.alison-desktop\connector
C:\Users\<user>\.alison-desktop\config\default.alison-desktop

Reiniciar (blue star) Alison Desktop. Estos archivos serán regenerados nuevamente y debe habilitar la aplicación nuevamente.

2️⃣ Otro programa está escuchando en el puerto 8004

Motivo:

Detectar qué otro programa genera el conflicto:

2.1- Abra una consola y ejecute el siguiente comando: netstat -ano | find "8004" para verificar que sí existe un programa escuchando y obtener el PID.

Image Modified

2.2 Ejecute en la misma consola el comando: tasklist /fi "PID eq "<nro marcado en rojo>" para verificar qué proceso esta escuchando en el puerto “8004”

Image Modified

Solución:

desinstale o cierre el programa que genera conflicto.

3️⃣ Solucionar con Plug-in

Instalar Alison Extension (Plug-in)


(warning) En caso de no poder resolver el inconveniente:

Para poder avanzar con un diagnóstico más preciso, necesitamos que por favor acceda al los datos del certificado tal como se muestran en la siguientes imagenes:

Image Modified

Es necesario que nos remita la información del certificado, tal como se muestra a continuación, donde se puede ver en detalle la descripción correspondiente a “Issuer Name”.

Image Modified

Info
Nota: si encuentra que esta información contiene algún error, o es incompleta, por favor comunicarse con soporte@certisur.com
Muchas gracias.